Juju development now requires Go 1.11


#1

Heads Up!

The 3 active Juju branches:

  • 2.3
  • 2.4
  • develop

now require the use of Go 1.11 rather than Go 1.10.

So update your Go snap:

sudo snap refresh go --channel 1.11/stable

The main changes to the code were just go fmt related.