Fresh “OpenStack with Nova-LXD” deployment - issues


#1

Hello all,

I just successfully built “OpenStack with Nova-LXD” with conjure-up and am able to launch instances without issue. The instances fail to get an IP address though, whether I use the “external” network, or the “internal” network - also the “internal” network conjure-up configured has no associated gateway address on the machine anywhere.

Further to that, I uploaded a known good CentOS qcow2 image that I’ve had loaded and working in DevStack or PackStack before (don’t recall which, I’ve been through every possible option 23 times trying to get all this working), and Horizon is telling me “… unacceptable: Bad image format”

Any help or pointers for troubleshooting would be GREATLY appreciated!

Ubuntu 18.04.1 server btw, wired networking.


#2

I can’t console into any of the instances either.

I went in and edited the external subnet and enabled DHCP, then I built a new instance using it and it still didn’t get an IP.

Instances on the internal network get IP addresses, but I guess the OpenStack router NATs them? Because I can’t reach that subnet - and since I can’t console in, I can’t verify if they have any connectivity :confused:


#3

Thank you for your post. Correct: in an all-in-one deployment, the tenant/project network is behind a neutron router (NAT). In order to access them from the host, or outside the host, a floating ip address range would need to be defined, and a floating ip address would need to be assigned to the instance.

It sounds like you are wanting to launch instances in the deployed cloud, and have those instances wired with L2 access to your local network (as well as L3 addresses from your local network). That can be done, but that is not the scenario provided by the “openstack with novalxd” conjure-up spell.

I’ve tested the current conjure-up release on a single machine, and I’m able to launch instances and ssh into them. If you’re seeing that that isn’t working, please raise a bug against the spell with additional detail. Thanks again!