Build dir not specified via command-line or environment


#1

Hi all,

I’m trying to suppress this message build: Build dir not specified via command-line or environment; defaulting to /tmp/charm-builds. It’s appearing, even with JUJU_REPOSITORY set and i can’t find the correct env var to set in the docs.

Thanks!


#2

That’s odd, it should be honoring JUJU_REPOSITORY. You could try setting CHARM_BUILD_DIR instead.


#3

Yeah, I tried that too @cory_fu; not sure if it’s a bug or just not documented.