Remove blocked charms


#1

Hi folks

I’m trying to destroy a k8s model with 2 blocked mariadb charms because they failed to get any storage. But destroy-model is waiting for them to shut down, but they don’t. Any way to give them a proper send off?


#2

Juju across all substrates currently has in issue where units that are stuck (for whatever reason) prevent model destruction. This issue is something that’s being worked on this cycle and we’ll hopefully have a better solution in the May timeframe when 2.6 is released.


#3

If it is just that they are in an error state, you can run ‘juju resolved UNIT’ and it will try the next hook. So you may need to run it a few times before they progress all the way to stopped and dying. (That is some of the work that Ian mentions we want to focus on this cycle.)


#4

Yeah i tried that but it didn’t seem to kick it out of error state even with --no-retry


#5

So even with --no-retry you’ll need to run the resolved command for each hook set to run on the unit so it can take 5+ juju resolved --no-retry xxxx to get through at times.


#6


#7

And if you try to remove it again does it try to keep moving it towards deletion?


#8

No it keeps telling me its already resolved.