Pending machines blocks all


#1

I’m stuck in a situation where I have a model where I tried to deploy a machine which gets stuck in a “pending” state (See my comment in this bug): https://bugs.launchpad.net/juju/+bug/1607971

So, any subsequent deployment will not happen.

I end up in a situation where my model is totally un-usable since no new machines can be provisioned and I’m left with a broken model.

To reproduce, try like this in AWS (eu-west-1):

juju add-model bork
juju deploy cs:~asbalderson/noop-centos-0
juju remove-machine 4 --force --debug
juju deploy ubuntu

Not even juju destroy-model bork helps here as the machines ends up in state: stopped.

Is there any way to “kill-machine” or even “kill-model” in juju or how can I save a model getting blocked like this?

The controller is on 2.5.1

== Update March 24 ==
It seems that this now has affect across the whole controller. I can get no more machines to deploy in any model. I’m suspecting that something has kicked in on a cloud basis even… scary.
Using the same aws cloud credentials via jaas works just fine.

@anastasia-macmood This also relates to what I wrote about models not getting removed. It even now seems to bog out the entire controller. Can this be related to the/my aws cloud provider even?


#2

@erik-lonroth,

I am sorry you got stuck but it is kind of brilliant for me as I am currently working in this area \o/

Couple of questions here (although I would prefer to see this bugged up):

  1. What series are you using? I see you are deploying centos-aimed charm… Please show details for model, machines, applications, etc. Maybe ‘juju status --format yaml’ :smiley:
  2. I am not seeing reference to storage in your example but I want you to clarify - did your initial scenario involve storage?

kill-model has been discussed and will be worked on as soon as we can. At this stage, the focus is on providing --force to ‘remove-application’ and ‘remove-unit’. This work is related to the destroy model and what you are describing…