Model migrate


#1

Hi all, I have migrated a model between two controllers and on the new controller I can see and manage the model through the cli, I have no access in the GUI (same user, admin), I don’t even see it in the list of my models. Any ideas ?


#2

Cool that you got the model migrated. So I’m curious about the setup a bit more. Is the user account just the built in admin account or is this a different user? Does the user exist on both controllers? When you mention not seeing it in the GUI, did you load the GUI on the new controller address?

I’d love to get a little more into what you’ve got setup to see if we can figure out what’s up.


#3

On both controllers owner of the model is the built-in admin user. I have cross checked that I connect to the gui of the new controller and I also created with the cli a new model with a couple of apps and changes reflect to the gui as expected. The migrated model is not visible.

For the record, some thing that I noticed and let a bitter taste :slight_smile:

  • The cloud name have to be exactly the same
  • The cloud credentials need to be exactly same
  • If any unit/app is in the executing phase the migration fails, instead of waiting to become idle
  • After failed migrations some jujud-unit-* services failed randomly (no logs at the moment, but something like locked mutex if i recall correctly)

#4

SOLVED

I tried to export the model for backup reasons and it failed because could not find a user that had access to the model on the old controller. I have just created the user, without granting any roles or access to the model and then both the export and the gui worked.

Seems like a bug to me :slight_smile:


#5

Yes, we’ve got a bug and a todo for this 2.6 release to improve migrations in this way and make sure to audit the users on each end of the migration so that we warn/error if we know there’s something off between there.

Glad you got it going.