Juju offline


#1

Juju offline is not working. Controller creation in offline is not worked before but It was possible to deploy application from locally created image in offline. But today again when I was trying it is not working !!
juju installed from : snap install juju --classic
it was downloaded 2.6.5 may be . then back in 2.5.8-bionic-amd64 but still not working!!
Even If i back from offline to online, Juju is not working until I’m reboot my machine!!

just check my last topic:


#2

Sorry to hear that you’re encountering issues with offline mode. Could you please post the sequence of commands that you’re using and the error message you’re encountering?


#3
  1. first create a container: lxc launch ubuntu:18.04 test
  2. lxc exec test – /bin/bash to attach in test container and then install all application regurding charm installation.
  3. lxc publish test–alias juju/bionic/amd64 is used for create a image from container
    then use that image to deploy application.
  4. create a controller
  5. now goes for offline.
  6. after offline when i run juju status command, it is not responding.