Do charms need to be updated?


#1

Hello,

I’m interested in using the mariadb charm. But I see it still defaults to a very old version of it maria (10.1 which released 5 years ago) and only supports Trusty?

Is it possible to use this charm with newer versions of Ubuntu? Or are their any plans to update them? This is one of the featured charms on jaas.ai so it’s a bit sad to see it so far out of date.


Updating the "Unmaintained charms" process
#3

Many charms are indeed stale. It’s a weakness of the Juju ecosystem.

We have a process for promoting a user’s charms into the default namespace, but don’t have a great mechanism to deprecate charms or mark them as archived/dormant.