Disable ceph-csi on Kubernetes v1.13 with juju



I recently updated my bare-metal kubernetes cluster (deployed with juju) to v1.13. The cluster also includes a ceph installation (through juju). Since the update juju seems to automatically install the csi-rbdplugin on kubernetes. Both the csi-attacher and csi-plugin pods crash (assumably because I didn’t create the right ceph pools) and consume a lot of cpu resources. I’ve manually configured access to ceph on the cluster, would like to continue with the legacy version and disable the csi plugin. Is there a way to disable the plugin? cdk-addons seems to have an enable-ceph config flag, but I’m unable to configure it through juju config.

Any help would be appreciated!



@tvansteenburgh on the k8s cluster config setup here.


@rick_h thanks for taking the time to respond! I appreciate it! Would you be able to point me to some resources that could help my research on the matter or should I wait until @tvansteenburgh responds?

Thanks again!


Hi @henriblancke,

The officially supported way of using ceph on CDK now is to use the CSI plugin. I understand that you had it all configured in the past and wish I could think of an easy way to revert. If you’re willing to edit charm code, we still have the original path in order to support the original method for older versions of Kubernetes. You could change the checks for the version and just force it to use the old version of the ceph code.

That seems like a maintenance nightmare, so the better option would be to convert that to a configuration option. If you’re willing to do that and submit a PR that would be great. If not, a bug to track it on our side would be very useful.



I’ve submitted a PR with a configuration option to disable CSI. This will make things work just like on 1.10, where a secret is created with ceph information and ceph tools are installed on the master. Comments are appreciated. There is currently concern about maintenance of multiple methods and also if this is even the requested approach.